D'Arcy from Winnipeg
Solution Architecture, Business & Entrepreneurship, Microsoft, and Adoption

Odd Citrix/Linksys Problem

Tuesday, November 21, 2006 1:56 PM

We have a computer that accesses a Citrix metaframe webpage over a VPN to launch Outlook, IE, etc.

If the computer is plugged directly into the cable modem, it works fine.

As soon as we put a Linksys router in between the computer and the modem though, we can't get any of the Citrix application icons to display in the web page and they won't load.

Anyone have any thoughts on this? Is there something with Linksys routers and Citrix that doesn't play nice?

D




Feedback

# re: Odd Citrix/Linksys Problem

Cisco routers block PPTP traffic by default. Cisco recently purchased Linksys. I haven't ever had problem running VPN traffic through a Linksys router, but I haven't played with any since Cisco purchased them. This is what I had to do with Cisco, maybe some of it applies to your situation:
http://geekswithblogs.net/thibbard/archive/2005/06/16/44008.aspx 11/21/2006 7:06 PM | Tim Hibbard

# re: Odd Citrix/Linksys Problem

LinkSys routers block PPTP and IPSec traffic by default. Log into the router (thru the web interface if it's a home router) and enable PPTP Pass thru and everything should work fine. 11/22/2006 6:29 AM | thorkia

# re: Odd Citrix/Linksys Problem

Thanks for the suggestions guys. here's teh weird thing though:

We set up a test environment in the office, with one of the terminals accessing the Citrix web interface through a linksys router, and no problems were encountered. There was no difference in the Linksys setup...I think. I'll double check the things you've suggested to make sure first.

Thanks again!

D 11/22/2006 7:16 AM | D'Arcy from Winnipeg

# re: Odd Citrix/Linksys Problem

Let me know how this ends up. I run into all kinds of weird network setups when I'm on site, and I'm sure this will happen to me in the future. 11/22/2006 9:42 AM | Tim Hibbard

# re: Odd Citrix/Linksys Problem

You guys rock, thats the answer I needed.
Keep it up! 12/11/2006 12:10 PM | Troy Norris

# re: Odd Citrix/Linksys Problem

Just to clarify, my side was the Cisco 501 pix, a new install, I could ping and everything looked fine. (The Linksys was already configured for PPTP passthrough) so adding the fixup protocol pptp 1723 on the Pix made everything better... life is good (finally)
TN 12/11/2006 12:12 PM | Troy Norris

# re: Odd Citrix/Linksys Problem

We're seeing our work at home group with Linksys routers getting the error "The network connection to your applications was interrupted." I also get the error. I've got latest firmware, done port triggering, enabled pptp. Nothing helps. 10/21/2009 9:53 AM | Jan

Post a comment