Unable to debug .net 1.1 applications after installing .net framework 2.0

.NET Framework 2.0 (CodeName: Whidbey) is the buzz word around and most of us would have installed the BETA versions to try our hands.

However, after you install .NET Framework 2.0, if you continue to use Visual Studio.NET 2003 you may be unable to debug the applications developed in .NET 1.1. You may receive the error "Unable to start debugging on the webserver..."

The reason is, as a part of installation, the framework registers the 2.0 version with the IIS using the aspnet_regiis.exe -i utility and the script mappings for the virtual directories get updated to 2.0 version.

Therefore, debugging .net 1.1 applications may fail.

The Resolution for this is to change the script mappings in the IIS - virtual directory settings for the application.

Once you install .NET Framework 2.0, you will be able to find the ASP.NET Tab in the Virtual Directory Properties in IIS.

The following steps provide resolution.

1. Type inetmgr from your command prompt

2. Expand the relevant nodes to select your Virtual Directory.

3. Right Click on the virtual directory and select properties.

4. You will be able to see the ASP.NET Tab which has newly come up.

5. Click on the ASP.NET tab.

6. You will be able to see a Dropdownlist with .NET 2.0 and .NET 1.1 versions listed.

7. Select the 1.1 Version and click Apply and then click ok

Now you will be able to debug your applications developed in .NET 1.1 using Visual Studio.NET 2003.

There are other errors that you may receive when running .net 1.1 applications after installing .NET 2.0. which I will explain in next article.

Happy Programming!

Print | posted on Monday, April 25, 2005 7:54 AM

Comments on this post

# re: Unable to debug .net 1.1 applications after installing .net framework 2.0

Requesting Gravatar...
I'm not able to get the newly generated tab called ASP.NET in IIS Virtual directory folder list. I have both vs2003 and vs2005 installed in my system and the above mentioned error is coming still. Please suggest
Left by vasan on Mar 17, 2006 3:08 AM

# re: Unable to debug .net 1.1 applications after installing .net framework 2.0

Requesting Gravatar...
What you are saying is keep running the .NET 1.1 framework if you use Visual Studio 2003. What if you want to debug an application that is having issues with the .NET 2.0 framework.
Left by Bob on Aug 16, 2006 2:16 PM

# re: Unable to debug .net 1.1 applications after installing .net framework 2.0

Requesting Gravatar...
oh, thanks very much. it worked very well.
Left by craig zhang on Nov 24, 2006 6:46 AM

# re: Unable to debug .net 1.1 applications after installing .net framework 2.0

Requesting Gravatar...
Once code written .NET 2003 has been debugged by making a call to the same from .NET 2005, and again is I try to open the .NET 2003 project I am unable to debug.
The error thrown is access denied, but I am an member in both administrator and Debuggers users group
Left by Jaya on Jan 02, 2007 7:26 AM

# Michael Wright

Requesting Gravatar...
The 9802 William Moore blog
Left by Lisa Jones on Apr 19, 2007 9:55 AM

# Christopher Brown

Requesting Gravatar...
The 4120 Anthony Wilson blog
Left by Kimberly Gonzalez on Apr 24, 2007 4:05 PM

# Lisa Lee

Requesting Gravatar...
The 7635 George Hall blog
Left by Margaret Lopez on Apr 24, 2007 10:36 PM

# re: Unable to debug .net 1.1 applications after installing .net framework 2.0

Requesting Gravatar...
thanks a ton. this post was really helpfulto me. i was struggling for quite sometime, being unable to debug my solution and couldnot figure out the problem exactly. this one helped me resolve the issue. thanks.
Left by sindhuja on Jan 03, 2008 4:25 PM

# re: Unable to debug .net 1.1 applications after installing .net framework 2.0

Requesting Gravatar...
Thanks Harish !!

You help me go one step forward !!

Regards
Satyam
Left by Satyam on Feb 29, 2008 10:23 AM

# re: Unable to debug .net 1.1 applications after installing .net framework 2.0

Requesting Gravatar...
The error thrown is access denied, but I am an member in both administrator and Debuggers users group
Left by mario oyunları on Sep 21, 2009 10:44 AM

# re: Unable to debug .net 1.1 applications after installing .net framework 2.0

Requesting Gravatar...
I was struggling for quite sometime, being unable to debug my solution and couldnot figure out the problem exactly.
ladies Shoes
Left by jack on Jan 04, 2011 6:31 PM

# Unable to see .net 1.1 applications after installing .net framework 2.0

Requesting Gravatar...
we want to install .net 1.1. But allready intalled 2.0 version plase suggest.
Left by Sarwan Kumar on Dec 27, 2011 11:17 AM

Your comment:

 (will show your gravatar)