jQuery 2.0 drops support for legacy IE (IE6, IE7, IE8)

jQuery upgrades may not be as reverse compatible as you may think. Starting from version 2 of jQuery, IE6, IE7 and yes also IE8 will no longer be supported. These are now considered legacy browsers. You will need to stop any upgrades to jQuery until your SLA states that IE8 is no longer supported and remain in jQuery 1.9.

Some of the reasons for not supporting IE8 and before:

- Remove all the code clutter in the jQuery library with code that has to deal with IE browser compatibility issues between IE6, 7 and 8 and the newer IE versions, the latter being more compliant.
- IE6 and 7 may have fallen to below 2% generally, that does not mean that that is true for your client base. In the oil and gas industry some clients are years behind and you may have 50% or more of clients remain on IE8 or older for the foreseeable future.
- The difference between browser engines has become almost negligible, as it should be. So one of the greatest goals of jQuery to abstract that out for developers is no longer needed, for most part anyway. 
- CSS3 features like animations basically replace the need for jQuery’s 2.0 animations and effects.

If the need is still there to support IE8 or before, but you also want to upgrade, then use conditional comments:
<!--[if lt IE 9]>
    <script src="jQuery-1.9.0.js"></script>
<![endif]-->
<!--[if gte IE 9]><!-->
    <script src="jQuery-2.0.0.js"><</script>
<!--<![endif]-->

Print | posted @ Thursday, October 31, 2013 9:32 AM

Comments on this entry:

Gravatar # re: jQuery 2.0 drops support for legacy IE (IE6, IE7, IE8)
by Ryan at 10/31/2013 1:52 PM

jQuery 1.x and 2.x have the same API, meaning you can do everything in 1.x that you can do in 2.x. The only difference is that 2.x has removed a lot of old code that was just a polyfill for old IEs.

So you can continue to update jQuery to get all of the new features, as long as you stay with 1.x (the most current version is 1.10.2)
Gravatar # http://neymar-trikot-kinder.greatbyeight.net
by neymar trikot kinder at 11/6/2013 9:57 AM

It is good to locate a internet site about my curiosity. My first visit to your site is been a massive help. Thank you for the endeavours you been placing on producing. your website such an exciting and useful area to look through through.
neymar trikot kinder http://neymar-trikot-kinder.greatbyeight.net
Gravatar # re: jQuery 2.0 drops support for legacy IE (IE6, IE7, IE8)
by Rahul Rai at 1/14/2015 12:31 PM

The best Jquery option is to touch with modern browsers. Mobile phone
Post A Comment
Title:
Name:
Email:
Comment:
Verification: